
—  TIME  LINE  — —  SOUND  EDITOR  —

—  VIRTUAL  CONTROL  SURFACE  —

The prototypes are categorized by function or technique. 
Clicking on a category name here changes the list of proto-
types that appears at the right.

—  SYSTEM  PROTOTYPES  —

Select a prototype by clicking on its icon, or choose Find pro-
totype… from the Action menu (Cmd+B) anywhere in Kyma to 
search for a prototype by name. This prototype is selected. 
The Action and Info menus refer to this Sound. Press the 
Control or Command key along with Space Bar (Cmd+Space) to compile, load and start (or play) this proto-
type. Click and drag the prototype into a time line, Sound editor, or Sound file window to use it in your work.

—  STATUS FROM FILE MENU  —
Indicates the amount of memory Kyma is using on your computer. Leave this window open so that Kyma 
can do memory recycling automatically for you. Click Recycle if the meter goes into the red. 

Displays the name of the global map file currently in use. The global map associates memorable control
ler names, like !DutyCycle, with real MIDI channels and controller numbers.

Shows the inputs expected by the Sound currently playing: audio, MIDI controllers, and/or MIDI key
board.

—  SPECTRUM  EDITOR  —

Double-click a Sound to edit 
its parameters. The edited 
Sound’s parameters are shown 
at the bottom of the window, 
and its icon is grayed out.

Click a Sound to select it. Use 
Cmd+Space to audition the se
lected Sound, Enter to change 
its name. The Action and Info 
menus refer to this Sound. 

A cyan halo surrounds the replaceable input. The replaceable input 
Sound is replaced when you drag the Sound being edited onto another 
Sound in the time line or onto a line in a Sound editor, or use it with a re
placement input in the Sound browser. To set the replaceable input, se
lect a Sound and choose Set replaceable input from the Action menu.

The Sound editor shows the signal flow between Sounds and the parameters of 
those Sounds.

Double-clicking a Sound in the time line or Sound file window opens the Sound ed
itor on a copy of that Sound. The changes you make in the Sound editor are not 
saved back into the time line or Sound file window until the Sound editor is 
closed. Use Save from the File menu to save back the changes without closing the 
editor window.

These are the parameters of the Sound double-clicked in the signal flow diagram.

A parameter with a cyan background and italic name is a hot parameter. Hot param
eters can be controlled by any combination of constant values, values from MIDI or 
on-screen controllers, the output of another Sound, or arithmetic expressions.

A parameter with a white background and non-italicized name is a constant pa
rameter. A constant parameter has a fixed value for the duration of the Sound.

The top part of the editor is the signal flow diagram. A stereo signal travels along 
each line from left to right. A thick line with a number in a box indicates that a 
signal is used more than once in the destination module (as in the lower window).

To insert a Sound into the signal flow, drag the Sound onto a line connecting two 
Sounds. To delete a Sound, click on its icon to select it, then press Delete. To replace 
a Sound with a copy of another Sound, drag the other Sound on top of the Sound to 
be replaced. To route the same Sound to two or more places, hold down Control or 
Option while dragging. Alternatively, use Paste or Paste special… from the Edit menu.

Drag this line up or down to adjust the size of the parameter area. To expand to 
the maximum size, double click in the background of the parameter area.

This is the type of the Sound 
being edited. Hold the mouse 
over this area for a descrip
tion of the Sound type.

This is the name of one of the 
Sound’s parameters. Hold the 
mouse over the name for a de
scription of the parameter.

Signal inputs to a Sound appear in both the signal flow diagram and in the Sound’s 
parameters. To change the input, cut, copy, paste, or drag Sounds into the param
eter field, or onto the icon of the old input in the signal flow diagram. The signal 
flow diagram will not be updated until you double-click a different Sound or dou
ble-click in the background of the signal flow diagram.

Can’t remember what arithmetic can be used in parame
ter fields? Ctrl+Shift+H lets you choose from a list.

Can’t see everything in a field? Use Large window… from 
the Edit menu (Ctrl+L) to expand it to full screen size.

If a field flashes when you play the Sound, it indicates 
an error in the field’s value.

Parameters can be controlled by Sounds acting as 
LFOs. To insert a Sound into a hot parameter field, 
Copy the Sound, and then Paste it into the field. Use 
L for left, R for right, or M for mono mix.

Hot parameter fields can contain Event Values control
led by MIDI or the Virtual Control Surface. Event Val
ues can be inserted by hitting the Escape key and mov
ing a MIDI controller or playing the MIDI keyboard 
(one key for !KeyPitch, two keys for !KeyDown, three 
keys for !KeyVelocity), choosing Paste hot… from the 
Edit menu, or by typing ! followed by any name.

Click this button to choose a file from a standard file 
dialog. Use Shift+click to get information about the 
current file. Use Control+click or Command+click to 
open an editor on the current file.

The virtual control surface (VCS) is a control panel or user 
interface for the currently playing Sound. It stores control 
settings in presets and alternative graphical arrangements 
of the controller widgets in layouts.

The top part of the VCS contains controls for selecting and 
editing presets and layouts. The bottom portion contains 
the graphical controls for interacting with the Sound.

Click the triangle to choose a preset from 
a list. Click the camera (or click the name 
and press Enter) to take a snapshot of 
the current settings.

Click the dice to set controllers randomly. 
Click a controller label (making it gray) to 
keep the dice from changing that controller.

These are the layout controls. Click the 
triangle to choose the controller layout 
from a list of predefined layouts.

Click the padlock to unlock/lock the 
VCS. When unlocked, the MIDI map
ping, type, range, and location of the 
controllers can be edited (see below).

Clicking the padlock at the upper right corner of the virtual 
control surface unlocks the layout and opens the VCS editor.

The upper portion of the editor displays a list of layouts for 
the currently playing Sound. Click to select one or Shift+click 
to select several layouts. The buttons below the list open 
pop-up menus for adding, merging and removing layouts (Lay
out…); arranging the selected controller widgets (Arrange…); 
and adding and removing controller widgets (Options…).

The lower portion of the editor provides a way to edit the se
lected controller widget(s): its MIDI channel and controller 
number, its label, its type (fader, button, etc.), whether it has 
an associated number field, its taper (linear or log), its mini
mum, maximum and gridding values, and its screen location.

Select widgets by clicking in the VCS window (hold down Shift key to 
extend the selection), drawing a box around a group (hold down Com
mand or Control to start within a widget), or by selecting a name using 
Selected Value in the editor.

To quickly assign a MIDI controller to a widget, select the widget, 
press the Escape key, and move the controller.

Click & drag a corner or edge of a widget to resize it; click & drag 
from the center to move it. Click, press the Shift key, then drag to 
move only vertically or horizontally. While resizing or moving a widg
et, the edges of other widgets act as snap-to guides to aid placement.

The spectrum editor displays the amplitude and frequency envelopes of sine 
wave components to be used during additive resynthesis. Each horizontal 
track represents a single sine wave. Color indicates the amplitude of the sine 
wave, vertical position indicates the frequency of the sine wave, and horizon
tal position indicates time. The spectrum editor uses the Capybara for real 
time auditioning of the resynthesis while editing.

The yellow scrub bar can be moved with the mouse, with MIDI pitch bend, or 
left or right arrow keys. While the scrub bar is moving, the resynthesis will play.

Markers indicate labeled time points and time segments for cutting or audi
tioning. The white marker is selected and its time position and label are dis
played at the top of the editor.

Click a marker to select it; the scrub bar moves to the marker time. Press 
Enter to rename the selected marker; use the Delete key or Cut from the 
Edit menu to remove the selected marker.

These buttons do the following: creates a marker at the scrub bar time; pla
ces the start marker at the scrub bar; places the end marker at the scrub 
bar; and sets pre- and post-roll play times.

These buttons do the following: play the entire spectrum; play the selection; 
play the selection between start and end markers; and play the selection out
side of start and end markers.

Information on the track under the cross hair cursor is displayed here.

Zero the amplitude of the selected tracks by choosing Clear from Edit menu. 
Grayed tracks have zeroed (cleared) amplitudes.

These buttons do the following: modify the selection in various ways; cut the 
time between the start and end markers; and switch in and out of drawing mode.

These buttons do the following: zoom the display all the way out; switch be
tween time-frequency and time-amplitude display modes; switch between iso
lated-dot and connected-dot between spectral frames; select tracks and 
frames based on various criteria.

Selected tracks are brighter. Select by clicking on an individual track, or by 
drawing a box around a region to select. Hold the Shift key while selecting to 
add to or remove from the current selection. Select a track between 1 and 10 
by pressing a number key (1-9, 0). Up and down arrow keys select next higher 
or lower track.

Create a Sound to play the selected part of the spectrum by choosing Copy 
from Edit menu, then Paste into a time line, Sound editor, or Sound file window.

Hold down the Control or Command key while drawing a box to zoom in on a 
specific region.

Kyma automatically displays comments from Annotation mod
ules in your Sound. You can also add text using the VCS editor.

Spectrum and waveform displays come from SpectrumAna
lyzer and OscilloscopeDisplay Sounds or by playing the Sound 
from Spectrum analyzer or Oscilloscope in the Info menu. 
The axes of the spectrum are linear frequency and dB magni
tude. The axes of the oscilloscope are time and amplitude.

Compress or expand the frequency, magnitude, time or am
plitude axes with these buttons.

All controls come from Event Values (hot variables) in the 
Sound (for instance, !ModIndex). An Event Value can be dis
played as a fader, potentiometer, or continuous rotary (with 
or without the text field), or as text, buttons, or switches.

To change the value of a fader, potentiometer, or rotary, use the 
mouse (hold Shift down for fine adjustments), or enter a number 
into the box above the control and press Enter. Tab cycles 
through the boxes. If a MIDI device is mapped to the controller 
(though the global map, a MIDIMapper Sound, or the VCS it
self), the controller can be adjusted using the MIDI device.

If a CM Automation Motor Mix is attached to the Capybara 
and selected in the Kyma preferences, it will automatically 
show abbreviations of the controller names displayed in its 
LCD scribble strip, and its faders, rotaries, and buttons will 
be mapped to control the VCS.

—  SOUND  FILE  WINDOW  —
A Sound file contains a collection of Sounds and Sound folders. Use Sound files to 
keep related Sounds together. Sounds can be dragged between this window and 
time lines, Sound editors, and other Sound file windows.

This Sound is selected. Click any Sound icon to select it. The Action and Info 
menu operations refer to this Sound. Press Enter to change the name of the 
Sound. Press Ctrl+Space to compile, load and start the selected Sound.

This Sound is being edited (see Sound editor). Double-click any Sound’s icon to 
edit its structure and parameters.

This is a Sound collection. Use Collect… from the Action menu to place the select-
ed Sounds into a new collection.

—  STATUS FROM DSP MENU  —

—  SAMPLES FILE EDITOR  —

Time since currently playing Sound was 
started. Does not update after Sound 
ends or when DSP is stopped.

Last time code received via SMPTE LTC 
(L), SMPTE VITC (V), or MIDI time 
code (M).

Choose analog or digital audio interface 
for each input channel pair from the 
pull down list.

Choose either AES/EBU or S/PDIF as 
digital input and output format for 
groups of four inputs and outputs.

Status from the DSP menu displays audio levels and 
DSP usage in the Capybara. It also provides a way to 
configure the audio inputs and outputs.

Input peak level indicator. Click mouse to clear. Possible 
clipping if it shows >0< (meaning the signal reached 0 dB 
at some point). Output has a corresponding indicator.

Input and output level indicators. Lines indicate -10, -20, 
-40, -60, and -80 dB.

Approximate measure of current computational load on 
each DSP. Each line indicates approximately 20% usage.

Choose between internal and external sample rate clock 
sources from the pull down list.

Choose a sample rate from the pull down list.

Peak level in editing pane, and the 
duration, start, and end of the se
lection. Click to change units.

This is an overview of the entire 
file. Two channels are shown, even 
when editing single channel files.

This section is used to algorithmically generate waveforms. Use the 
triangle button to select a template from the list of templates. 
Modify the template parameters, and click Insert to evaluate the 
template and replace selection with the result.

The editing pane displays the portion of the file visible in the gray 
box in the overview. Click and drag in the overview, or use the scroll, 
expand, and compress buttons to navigate through the file.

The samples between these red lines are selected. Click and drag in 
this area to change the selection. Use Cut, Copy, Paste, Trim, and 
Clear selection in the Edit menu to alter the file. All changes in the 
editor are non-destructive; use Save or Save as… from the File 
menu to save the changes to the hard disk.

The gray box indicates the region of the file that is visible in the 
editing pane, below. Click and drag in this area to change the visible 
region. The red box indicates the current selection.

The buttons do the following: scroll one page to left; play selection; 
replace selection with a sample from disk; fit selection to window; 
compress time axis; expand time axis; compress level axis; expand 
level axis; additional options (including editing header information); 
and scroll one page to right.

Timing source, current time & time ruler

List of controllable parameters

Tracks and track settings

Control editor menus, info, transformations

Selected marker name & time; markers

Sounds with various durations & start times

Menus; selected Sound name, timing & color Transport controls, time line menus

Automated control of selected parameter

Time zoom-out, zoom-in, fit-window buttons

Value zoom-out and zoom-in buttons

Source of control: use pop-up menu to 
select a take, a MIDI controller, or 
another parameter from which the se
lected parameter will get its values.

Type of control: use pop-up menu to 
choose whether the selected parame
ter is automated, is controlled live, or 
is slaved to another parameter’s value.

Click to enable recording of 
the selected parameter when 
the time line is next played.

This parameter is selected.

The time and value of the first selected 
breakpoint. To move a point, enter its new 
time & value into these fields & press En
ter, or click & drag it to the new location.

Click to apply a transformation 
to the control. Hold the mouse 
over any button for a descrip
tion of its transformation.

Yellow time cursor indicates current time.

Dark background shows times 
when this control is active.

Automated control editor: click a breakpoint, draw a box, or Select all from Edit menu to select (Shift extends selection); Option or Ctrl 
& click to add; Delete key to delete; click & drag to move breakpoints (click, hold down Shift, then drag for vertical or horizontal move).

Click to choose audio input: a 
physical input, submix, or no 
input. The color-coded submix 
reverb is input for this track.

Pop-up menu to route track out
put: directly to physical outputs; 
or via pan controls (Angle, Radius, 
Panner & Distance) and speaker 
locations (Preferences under 
Edit menu) to physical outputs.

Click to set track MIDI channel.

Click to solo; Option or Control 
& click to mute. Use Shift key 
to solo/mute multiple tracks.

Yellow dot is virtual source location

Click to send track output to 
a submix. Submix is assigned 
color & slot in grid.

Mic & MIDI are green when 
live, red when recording

Double-click a Sound to edit it. Edit
ed Sounds are displayed in gray.

Drag this line up or down to 
adjust size of the track area.

The selected Sounds’ parameters.

Click a Sound, draw a box, or Select all from Edit menu to select (Shift extends 
selection); Delete key to delete; click & drag to change tracks or start time (click, 
hold down Shift, then drag for vertical or horizontal move); click & drag Sound 
end to change duration. Selected Sound parameters are displayed below on left. 

Drag & drop to add Sounds. Drag & drop onto 
a Sound to use it as the replacement input.

Click in the time ruler to send the 
yellow time cursor to that time.

The current time is displayed here. Enter a time & press 
Enter to move the yellow time cursor to a particular time.

Timing source: use pop-up menu to chase MIDI or SMPTE time 
code or MIDI timing clock; or to use an internal timing clock.

Click to select marker; drag marker to reposition it; Delete key removes marker.The selected marker’s name and time. Enter a new name or time and 
press Enter. Use Ctrl+L to 
enter spaces into the name.

Start time, anchor time, duration, & end time of selected Sound(s). Enter a time & press Enter.The selected Sound’s name and polyphony. Enter a new name or 
polyphony & press Enter. Use Ctrl+L to enter spaces into name. 
Polyphony is the number of voices for keyboard-based Sounds.

Set time grid mode (free, quantized, mag
net); do time editing; choose time line colors.Set groups of controllers to live, 

automated, or record-enabled.

Play and pause (Space toggles, 
Ctrl+Æ plays, Ctrl+¨ rewinds & 
stops); go to prev & next marker, 
prev & next Sound; insert mark
er, spaced markers, anchor.

Click a Sound’s tab (the small box attached to the left edge of the icon) to show 
hidden inputs. Clicking again will hide the inputs. Click and drag a Sound to reposi
tion it. Hold down the Shift key to move the Sound and its inputs at the same time.

Set bar division or frame rate 
and beat or frame subdivision.

Set time displays to bars 
and beats or time code.

Each Sound in the list that is preceded by a cyan arrow (->) performs processing on an input (the re-
placeable input). These Sounds come with a default input, but a replacement input can be substituted 
for the default input, making it easy to quickly audition and create combinations of different process-
ing algorithms and source material. The following controls set the replacement input to use with 
Sounds that take replaceable inputs:

Click this button to replace the Sound’s original input with the previously selected replacement input.

This is the name of the previously selected replacement input.

Click here to make the Sound or file selected in the list become the replacement input.

Click here to make the first audio input channel of the Capybara become the replacement input.

Click to update the list when files or directories have been added or removed by other programs.

Play and stop buttons for auditioning the selected Sound or file. (Cmd+Space and Cmd+K are shortcuts.)

Check a box to show a specific kind of file or Sound in the list. The categories are, from left to right, 
unknown file types, folders, text files, global maps, tools, compiled Sound grids, MIDI files, samples or 
digital recordings, spectral analysis files, RE resonator files, group additive synthesis files, Sound files, 
Sound collections within Sound files, Sounds within Sound collections or Sound files, and time lines.

—  SOUND  BROWSER  —

Sounds, files and folders are listed here in the same color as the check boxes (e.g., blue for Sounds). A 
Sound that has been changed but not yet saved is displayed with a yellow triangle to the left of the 
name. Choose Save from the File menu to save the changes made to all Sounds.

Click a file to select it. Double-click a Sound or file to edit it. Click the triangle next to a folder to 
show or hide its contents (hold Control or Command key down to also open all sub-folders). Double-click 
a folder to open a Sound Browser on that folder.

Use the arrow keys to move the selection up or down. Use Find… from the Action menu (Cmd+F) to se-
lect a Sound or file by name. The Action and Info menus refer to the selection. Use Cmd+Space or the 
transport controls to audition the selection. Click and drag the selection into a time line, Sound editor, 
or Sound file window to use the selection in your work.

Information on the selected Sound, file or folder.
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—  TIME  LINE  — —  SOUND  EDITOR  —

—  VIRTUAL  CONTROL  SURFACE  —

The prototypes are categorized by function or technique. 
Clicking on a category name here changes the list of proto
types that appears at the right.

—  SYSTEM  PROTOTYPES  —

Select a prototype by clicking on its icon, or choose Find pro
totype… from the Action menu (Cmd+B) anywhere in Kyma to 
search for a prototype by name. This prototype is selected. 
The Action and Info menus refer to this Sound. Press the 
Control or Command key along with Space Bar (Cmd+Space) to compile, load and start (or play) this proto
type. Click and drag the prototype into a time line, Sound editor, or Sound file window to use it in your work.

—  STATUS FROM FILE MENU  —
Indicates the amount of memory Kyma is using on your computer. Leave this window open so that Kyma 
can do memory recycling automatically for you. Click Recycle if the meter goes into the red. 

Displays the name of the global map file currently in use. The global map associates memorable control
ler names, like !DutyCycle, with real MIDI channels and controller numbers.

Shows the inputs expected by the Sound currently playing: audio, MIDI controllers, and/or MIDI key
board.

—  SPECTRUM  EDITOR  —

Double-click a Sound to edit 
its parameters. The edited 
Sound’s parameters are shown 
at the bottom of the window, 
and its icon is grayed out.

Click a Sound to select it. Use 
Cmd+Space to audition the se
lected Sound, Enter to change 
its name. The Action and Info 
menus refer to this Sound. 

A cyan halo surrounds the replaceable input. The replaceable input 
Sound is replaced when you drag the Sound being edited onto another 
Sound in the time line or onto a line in a Sound editor, or use it with a re
placement input in the Sound browser. To set the replaceable input, se
lect a Sound and choose Set replaceable input from the Action menu.

The Sound editor shows the signal flow between Sounds and the parameters of 
those Sounds.

Double-clicking a Sound in the time line or Sound file window opens the Sound ed
itor on a copy of that Sound. The changes you make in the Sound editor are not 
saved back into the time line or Sound file window until the Sound editor is 
closed. Use Save from the File menu to save back the changes without closing the 
editor window.

These are the parameters of the Sound double-clicked in the signal flow diagram.

A parameter with a cyan background and italic name is a hot parameter. Hot param
eters can be controlled by any combination of constant values, values from MIDI or 
on-screen controllers, the output of another Sound, or arithmetic expressions.

A parameter with a white background and non-italicized name is a constant pa
rameter. A constant parameter has a fixed value for the duration of the Sound.

The top part of the editor is the signal flow diagram. A stereo signal travels along 
each line from left to right. A thick line with a number in a box indicates that a 
signal is used more than once in the destination module (as in the lower window).

To insert a Sound into the signal flow, drag the Sound onto a line connecting two 
Sounds. To delete a Sound, click on its icon to select it, then press Delete. To replace 
a Sound with a copy of another Sound, drag the other Sound on top of the Sound to 
be replaced. To route the same Sound to two or more places, hold down Control or 
Option while dragging. Alternatively, use Paste or Paste special… from the Edit menu.

Drag this line up or down to adjust the size of the parameter area. To expand to 
the maximum size, double click in the background of the parameter area.

This is the type of the Sound 
being edited. Hold the mouse 
over this area for a descrip
tion of the Sound type.

This is the name of one of the 
Sound’s parameters. Hold the 
mouse over the name for a de
scription of the parameter.

Signal inputs to a Sound appear in both the signal flow diagram and in the Sound’s 
parameters. To change the input, cut, copy, paste, or drag Sounds into the param
eter field, or onto the icon of the old input in the signal flow diagram. The signal 
flow diagram will not be updated until you double-click a different Sound or dou
ble-click in the background of the signal flow diagram.

Can’t remember what arithmetic can be used in parame
ter fields? Ctrl+Shift+H lets you choose from a list.

Can’t see everything in a field? Use Large window… from 
the Edit menu (Ctrl+L) to expand it to full screen size.

If a field flashes when you play the Sound, it indicates 
an error in the field’s value.

Parameters can be controlled by Sounds acting as 
LFOs. To insert a Sound into a hot parameter field, 
Copy the Sound, and then Paste it into the field. Use 
L for left, R for right, or M for mono mix.

Hot parameter fields can contain Event Values control
led by MIDI or the Virtual Control Surface. Event Val
ues can be inserted by hitting the Escape key and mov
ing a MIDI controller or playing the MIDI keyboard 
(one key for !KeyPitch, two keys for !KeyDown, three 
keys for !KeyVelocity), choosing Paste hot… from the 
Edit menu, or by typing ! followed by any name.

Click this button to choose a file from a standard file 
dialog. Use Shift+click to get information about the 
current file. Use Control+click or Command+click to 
open an editor on the current file.

The virtual control surface (VCS) is a control panel or user 
interface for the currently playing Sound. It stores control 
settings in presets and alternative graphical arrangements 
of the controller widgets in layouts.

The top part of the VCS contains controls for selecting and 
editing presets and layouts. The bottom portion contains 
the graphical controls for interacting with the Sound.

Click the triangle to choose a preset from 
a list. Click the camera (or click the name 
and press Enter) to take a snapshot of 
the current settings.

Click the dice to set controllers randomly. 
Click a controller label (making it gray) to 
keep the dice from changing that controller.

These are the layout controls. Click the 
triangle to choose the controller layout 
from a list of predefined layouts.

Click the padlock to unlock/lock the 
VCS. When unlocked, the MIDI map-
ping, type, range, and location of the 
controllers can be edited (see below).

Clicking the padlock at the upper right corner of the virtual 
control surface unlocks the layout and opens the VCS editor.

The upper portion of the editor displays a list of layouts for 
the currently playing Sound. Click to select one or Shift+click 
to select several layouts. The buttons below the list open 
pop-up menus for adding, merging and removing layouts (Lay-
out…); arranging the selected controller widgets (Arrange…); 
and adding and removing controller widgets (Options…).

The lower portion of the editor provides a way to edit the se-
lected controller widget(s): its MIDI channel and controller 
number, its label, its type (fader, button, etc.), whether it has 
an associated number field, its taper (linear or log), its mini-
mum, maximum and gridding values, and its screen location.

Select widgets by clicking in the VCS window (hold down Shift key to 
extend the selection), drawing a box around a group (hold down Com-
mand or Control to start within a widget), or by selecting a name using 
Selected Value in the editor.

To quickly assign a MIDI controller to a widget, select the widget, 
press the Escape key, and move the controller.

Click & drag a corner or edge of a widget to resize it; click & drag 
from the center to move it. Click, press the Shift key, then drag to 
move only vertically or horizontally. While resizing or moving a widg-
et, the edges of other widgets act as snap-to guides to aid placement.

The spectrum editor displays the amplitude and frequency envelopes of sine 
wave components to be used during additive resynthesis. Each horizontal 
track represents a single sine wave. Color indicates the amplitude of the sine 
wave, vertical position indicates the frequency of the sine wave, and horizon
tal position indicates time. The spectrum editor uses the Capybara for real 
time auditioning of the resynthesis while editing.

The yellow scrub bar can be moved with the mouse, with MIDI pitch bend, or 
left or right arrow keys. While the scrub bar is moving, the resynthesis will play.

Markers indicate labeled time points and time segments for cutting or audi
tioning. The white marker is selected and its time position and label are dis
played at the top of the editor.

Click a marker to select it; the scrub bar moves to the marker time. Press 
Enter to rename the selected marker; use the Delete key or Cut from the 
Edit menu to remove the selected marker.

These buttons do the following: creates a marker at the scrub bar time; pla
ces the start marker at the scrub bar; places the end marker at the scrub 
bar; and sets pre- and post-roll play times.

These buttons do the following: play the entire spectrum; play the selection; 
play the selection between start and end markers; and play the selection out
side of start and end markers.

Information on the track under the cross hair cursor is displayed here.

Zero the amplitude of the selected tracks by choosing Clear from Edit menu. 
Grayed tracks have zeroed (cleared) amplitudes.

These buttons do the following: modify the selection in various ways; cut the 
time between the start and end markers; and switch in and out of drawing mode.

These buttons do the following: zoom the display all the way out; switch be
tween time-frequency and time-amplitude display modes; switch between iso
lated-dot and connected-dot between spectral frames; select tracks and 
frames based on various criteria.

Selected tracks are brighter. Select by clicking on an individual track, or by 
drawing a box around a region to select. Hold the Shift key while selecting to 
add to or remove from the current selection. Select a track between 1 and 10 
by pressing a number key (1-9, 0). Up and down arrow keys select next higher 
or lower track.

Create a Sound to play the selected part of the spectrum by choosing Copy 
from Edit menu, then Paste into a time line, Sound editor, or Sound file window.

Hold down the Control or Command key while drawing a box to zoom in on a 
specific region.

Kyma automatically displays comments from Annotation mod-
ules in your Sound. You can also add text using the VCS editor.

Spectrum and waveform displays come from SpectrumAna-
lyzer and OscilloscopeDisplay Sounds or by playing the Sound 
from Spectrum analyzer or Oscilloscope in the Info menu. 
The axes of the spectrum are linear frequency and dB magni-
tude. The axes of the oscilloscope are time and amplitude.

Compress or expand the frequency, magnitude, time or am-
plitude axes with these buttons.

All controls come from Event Values (hot variables) in the 
Sound (for instance, !ModIndex). An Event Value can be dis-
played as a fader, potentiometer, or continuous rotary (with 
or without the text field), or as text, buttons, or switches.

To change the value of a fader, potentiometer, or rotary, use the 
mouse (hold Shift down for fine adjustments), or enter a number 
into the box above the control and press Enter. Tab cycles 
through the boxes. If a MIDI device is mapped to the controller 
(though the global map, a MIDIMapper Sound, or the VCS it-
self), the controller can be adjusted using the MIDI device.

If a CM Automation Motor Mix is attached to the Capybara 
and selected in the Kyma preferences, it will automatically 
show abbreviations of the controller names displayed in its 
LCD scribble strip, and its faders, rotaries, and buttons will 
be mapped to control the VCS.

—  SOUND  FILE  WINDOW  —
A Sound file contains a collection of Sounds and Sound folders. Use Sound files to 
keep related Sounds together. Sounds can be dragged between this window and 
time lines, Sound editors, and other Sound file windows.

This Sound is selected. Click any Sound icon to select it. The Action and Info 
menu operations refer to this Sound. Press Enter to change the name of the 
Sound. Press Ctrl+Space to compile, load and start the selected Sound.

This Sound is being edited (see Sound editor). Double-click any Sound’s icon to 
edit its structure and parameters.

This is a Sound collection. Use Collect… from the Action menu to place the select
ed Sounds into a new collection.

—  STATUS FROM DSP MENU  —

—  SAMPLES FILE EDITOR  —

Time since currently playing Sound was 
started. Does not update after Sound 
ends or when DSP is stopped.

Last time code received via SMPTE LTC 
(L), SMPTE VITC (V), or MIDI time 
code (M).

Choose analog or digital audio interface 
for each input channel pair from the 
pull down list.

Choose either AES/EBU or S/PDIF as 
digital input and output format for 
groups of four inputs and outputs.

Status from the DSP menu displays audio levels and 
DSP usage in the Capybara. It also provides a way to 
configure the audio inputs and outputs.

Input peak level indicator. Click mouse to clear. Possible 
clipping if it shows >0< (meaning the signal reached 0 dB 
at some point). Output has a corresponding indicator.

Input and output level indicators. Lines indicate -10, -20, 
-40, -60, and -80 dB.

Approximate measure of current computational load on 
each DSP. Each line indicates approximately 20% usage.

Choose between internal and external sample rate clock 
sources from the pull down list.

Choose a sample rate from the pull down list.

Peak level in editing pane, and the 
duration, start, and end of the se
lection. Click to change units.

This is an overview of the entire 
file. Two channels are shown, even 
when editing single channel files.

This section is used to algorithmically generate waveforms. Use the 
triangle button to select a template from the list of templates. 
Modify the template parameters, and click Insert to evaluate the 
template and replace selection with the result.

The editing pane displays the portion of the file visible in the gray 
box in the overview. Click and drag in the overview, or use the scroll, 
expand, and compress buttons to navigate through the file.

The samples between these red lines are selected. Click and drag in 
this area to change the selection. Use Cut, Copy, Paste, Trim, and 
Clear selection in the Edit menu to alter the file. All changes in the 
editor are non-destructive; use Save or Save as… from the File 
menu to save the changes to the hard disk.

The gray box indicates the region of the file that is visible in the 
editing pane, below. Click and drag in this area to change the visible 
region. The red box indicates the current selection.

The buttons do the following: scroll one page to left; play selection; 
replace selection with a sample from disk; fit selection to window; 
compress time axis; expand time axis; compress level axis; expand 
level axis; additional options (including editing header information); 
and scroll one page to right.

Timing source, current time & time ruler

List of controllable parameters

Tracks and track settings

Control editor menus, info, transformations

Selected marker name & time; markers

Sounds with various durations & start times

Menus; selected Sound name, timing & color Transport controls, time line menus

Automated control of selected parameter

Time zoom-out, zoom-in, fit-window buttons

Value zoom-out and zoom-in buttons

Source of control: use pop-up menu to 
select a take, a MIDI controller, or 
another parameter from which the se
lected parameter will get its values.

Type of control: use pop-up menu to 
choose whether the selected parame
ter is automated, is controlled live, or 
is slaved to another parameter’s value.

Click to enable recording of 
the selected parameter when 
the time line is next played.

This parameter is selected.

The time and value of the first selected 
breakpoint. To move a point, enter its new 
time & value into these fields & press En
ter, or click & drag it to the new location.

Click to apply a transformation 
to the control. Hold the mouse 
over any button for a descrip
tion of its transformation.

Yellow time cursor indicates current time.

Dark background shows times 
when this control is active.

Automated control editor: click a breakpoint, draw a box, or Select all from Edit menu to select (Shift extends selection); Option or Ctrl 
& click to add; Delete key to delete; click & drag to move breakpoints (click, hold down Shift, then drag for vertical or horizontal move).

Click to choose audio input: a 
physical input, submix, or no 
input. The color-coded submix 
reverb is input for this track.

Pop-up menu to route track out
put: directly to physical outputs; 
or via pan controls (Angle, Radius, 
Panner & Distance) and speaker 
locations (Preferences under 
Edit menu) to physical outputs.

Click to set track MIDI channel.

Click to solo; Option or Control 
& click to mute. Use Shift key 
to solo/mute multiple tracks.

Yellow dot is virtual source location

Click to send track output to 
a submix. Submix is assigned 
color & slot in grid.

Mic & MIDI are green when 
live, red when recording

Double-click a Sound to edit it. Edit
ed Sounds are displayed in gray.

Drag this line up or down to 
adjust size of the track area.

The selected Sounds’ parameters.

Click a Sound, draw a box, or Select all from Edit menu to select (Shift extends 
selection); Delete key to delete; click & drag to change tracks or start time (click, 
hold down Shift, then drag for vertical or horizontal move); click & drag Sound 
end to change duration. Selected Sound parameters are displayed below on left. 

Drag & drop to add Sounds. Drag & drop onto 
a Sound to use it as the replacement input.

Click in the time ruler to send the 
yellow time cursor to that time.

The current time is displayed here. Enter a time & press 
Enter to move the yellow time cursor to a particular time.

Timing source: use pop-up menu to chase MIDI or SMPTE time 
code or MIDI timing clock; or to use an internal timing clock.

Click to select marker; drag marker to reposition it; Delete key removes marker.The selected marker’s name and time. Enter a new name or time and 
press Enter. Use Ctrl+L to 
enter spaces into the name.

Start time, anchor time, duration, & end time of selected Sound(s). Enter a time & press Enter.The selected Sound’s name and polyphony. Enter a new name or 
polyphony & press Enter. Use Ctrl+L to enter spaces into name. 
Polyphony is the number of voices for keyboard-based Sounds.

Set time grid mode (free, quantized, mag
net); do time editing; choose time line colors.Set groups of controllers to live, 

automated, or record-enabled.

Play and pause (Space toggles, 
Ctrl+Æ plays, Ctrl+¨ rewinds & 
stops); go to prev & next marker, 
prev & next Sound; insert mark
er, spaced markers, anchor.

Click a Sound’s tab (the small box attached to the left edge of the icon) to show 
hidden inputs. Clicking again will hide the inputs. Click and drag a Sound to reposi
tion it. Hold down the Shift key to move the Sound and its inputs at the same time.

Set bar division or frame rate 
and beat or frame subdivision.

Set time displays to bars 
and beats or time code.

Each Sound in the list that is preceded by a cyan arrow (Æ) performs processing on an input (the re
placeable input). These Sounds come with a default input, but a replacement input can be substituted 
for the default input, making it easy to quickly audition and create combinations of different process
ing algorithms and source material. The following controls set the replacement input to use with 
Sounds that take replaceable inputs:

Click this button to replace the Sound’s original input with the previously selected replacement input.

This is the name of the previously selected replacement input.

Click here to make the Sound or file selected in the list become the replacement input.

Click here to make the first audio input channel of the Capybara become the replacement input.

Click to update the list when files or directories have been added or removed by other programs.

Play and stop buttons for auditioning the selected Sound or file. (Cmd+Space and Cmd+K are shortcuts.)

Check a box to show a specific kind of file or Sound in the list. The categories are, from left to right, 
unknown file types, folders, text files, global maps, tools, compiled Sound grids, MIDI files, samples or 
digital recordings, spectral analysis files, RE resonator files, group additive synthesis files, Sound files, 
Sound collections within Sound files, Sounds within Sound collections or Sound files, and time lines.

—  SOUND  BROWSER  —

Sounds, files and folders are listed here in the same color as the check boxes (e.g., blue for Sounds). A 
Sound that has been changed but not yet saved is displayed with a yellow triangle to the left of the 
name. Choose Save from the File menu to save the changes made to all Sounds.

Click a file to select it. Double-click a Sound or file to edit it. Click the triangle next to a folder to 
show or hide its contents (hold Control or Command key down to also open all sub-folders). Double-click 
a folder to open a Sound Browser on that folder.

Use the arrow keys to move the selection up or down. Use Find… from the Action menu (Cmd+F) to se
lect a Sound or file by name. The Action and Info menus refer to the selection. Use Cmd+Space or the 
transport controls to audition the selection. Click and drag the selection into a time line, Sound editor, 
or Sound file window to use the selection in your work.

Information on the selected Sound, file or folder.
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—  TIME  LINE  — —  SOUND  EDITOR  —

—  VIRTUAL  CONTROL  SURFACE  —

The prototypes are categorized by function or technique. 
Clicking on a category name here changes the list of proto
types that appears at the right.

—  SYSTEM  PROTOTYPES  —

Select a prototype by clicking on its icon, or choose Find pro
totype… from the Action menu (Cmd+B) anywhere in Kyma to 
search for a prototype by name. This prototype is selected. 
The Action and Info menus refer to this Sound. Press the 
Control or Command key along with Space Bar (Cmd+Space) to compile, load and start (or play) this proto
type. Click and drag the prototype into a time line, Sound editor, or Sound file window to use it in your work.

—  STATUS FROM FILE MENU  —
Indicates the amount of memory Kyma is using on your computer. Leave this window open so that Kyma 
can do memory recycling automatically for you. Click Recycle if the meter goes into the red. 

Displays the name of the global map file currently in use. The global map associates memorable control
ler names, like !DutyCycle, with real MIDI channels and controller numbers.

Shows the inputs expected by the Sound currently playing: audio, MIDI controllers, and/or MIDI key
board.

—  SPECTRUM  EDITOR  —

Double-click a Sound to edit 
its parameters. The edited 
Sound’s parameters are shown 
at the bottom of the window, 
and its icon is grayed out.

Click a Sound to select it. Use 
Cmd+Space to audition the se
lected Sound, Enter to change 
its name. The Action and Info 
menus refer to this Sound. 

A cyan halo surrounds the replaceable input. The replaceable input 
Sound is replaced when you drag the Sound being edited onto another 
Sound in the time line or onto a line in a Sound editor, or use it with a re
placement input in the Sound browser. To set the replaceable input, se
lect a Sound and choose Set replaceable input from the Action menu.

The Sound editor shows the signal flow between Sounds and the parameters of 
those Sounds.

Double-clicking a Sound in the time line or Sound file window opens the Sound ed
itor on a copy of that Sound. The changes you make in the Sound editor are not 
saved back into the time line or Sound file window until the Sound editor is 
closed. Use Save from the File menu to save back the changes without closing the 
editor window.

These are the parameters of the Sound double-clicked in the signal flow diagram.

A parameter with a cyan background and italic name is a hot parameter. Hot param
eters can be controlled by any combination of constant values, values from MIDI or 
on-screen controllers, the output of another Sound, or arithmetic expressions.

A parameter with a white background and non-italicized name is a constant pa
rameter. A constant parameter has a fixed value for the duration of the Sound.

The top part of the editor is the signal flow diagram. A stereo signal travels along 
each line from left to right. A thick line with a number in a box indicates that a 
signal is used more than once in the destination module (as in the lower window).

To insert a Sound into the signal flow, drag the Sound onto a line connecting two 
Sounds. To delete a Sound, click on its icon to select it, then press Delete. To replace 
a Sound with a copy of another Sound, drag the other Sound on top of the Sound to 
be replaced. To route the same Sound to two or more places, hold down Control or 
Option while dragging. Alternatively, use Paste or Paste special… from the Edit menu.

Drag this line up or down to adjust the size of the parameter area. To expand to 
the maximum size, double click in the background of the parameter area.

This is the type of the Sound 
being edited. Hold the mouse 
over this area for a descrip
tion of the Sound type.

This is the name of one of the 
Sound’s parameters. Hold the 
mouse over the name for a de
scription of the parameter.

Signal inputs to a Sound appear in both the signal flow diagram and in the Sound’s 
parameters. To change the input, cut, copy, paste, or drag Sounds into the param
eter field, or onto the icon of the old input in the signal flow diagram. The signal 
flow diagram will not be updated until you double-click a different Sound or dou
ble-click in the background of the signal flow diagram.

Can’t remember what arithmetic can be used in parame
ter fields? Ctrl+Shift+H lets you choose from a list.

Can’t see everything in a field? Use Large window… from 
the Edit menu (Ctrl+L) to expand it to full screen size.

If a field flashes when you play the Sound, it indicates 
an error in the field’s value.

Parameters can be controlled by Sounds acting as 
LFOs. To insert a Sound into a hot parameter field, 
Copy the Sound, and then Paste it into the field. Use 
L for left, R for right, or M for mono mix.

Hot parameter fields can contain Event Values control
led by MIDI or the Virtual Control Surface. Event Val
ues can be inserted by hitting the Escape key and mov
ing a MIDI controller or playing the MIDI keyboard 
(one key for !KeyPitch, two keys for !KeyDown, three 
keys for !KeyVelocity), choosing Paste hot… from the 
Edit menu, or by typing ! followed by any name.

Click this button to choose a file from a standard file 
dialog. Use Shift+click to get information about the 
current file. Use Control+click or Command+click to 
open an editor on the current file.

The virtual control surface (VCS) is a control panel or user 
interface for the currently playing Sound. It stores control 
settings in presets and alternative graphical arrangements 
of the controller widgets in layouts.

The top part of the VCS contains controls for selecting and 
editing presets and layouts. The bottom portion contains 
the graphical controls for interacting with the Sound.

Click the triangle to choose a preset from 
a list. Click the camera (or click the name 
and press Enter) to take a snapshot of 
the current settings.

Click the dice to set controllers randomly. 
Click a controller label (making it gray) to 
keep the dice from changing that controller.

These are the layout controls. Click the 
triangle to choose the controller layout 
from a list of predefined layouts.

Click the padlock to unlock/lock the 
VCS. When unlocked, the MIDI map
ping, type, range, and location of the 
controllers can be edited (see below).

Clicking the padlock at the upper right corner of the virtual 
control surface unlocks the layout and opens the VCS editor.

The upper portion of the editor displays a list of layouts for 
the currently playing Sound. Click to select one or Shift+click 
to select several layouts. The buttons below the list open 
pop-up menus for adding, merging and removing layouts (Lay
out…); arranging the selected controller widgets (Arrange…); 
and adding and removing controller widgets (Options…).

The lower portion of the editor provides a way to edit the se
lected controller widget(s): its MIDI channel and controller 
number, its label, its type (fader, button, etc.), whether it has 
an associated number field, its taper (linear or log), its mini
mum, maximum and gridding values, and its screen location.

Select widgets by clicking in the VCS window (hold down Shift key to 
extend the selection), drawing a box around a group (hold down Com
mand or Control to start within a widget), or by selecting a name using 
Selected Value in the editor.

To quickly assign a MIDI controller to a widget, select the widget, 
press the Escape key, and move the controller.

Click & drag a corner or edge of a widget to resize it; click & drag 
from the center to move it. Click, press the Shift key, then drag to 
move only vertically or horizontally. While resizing or moving a widg
et, the edges of other widgets act as snap-to guides to aid placement.

The spectrum editor displays the amplitude and frequency envelopes of sine 
wave components to be used during additive resynthesis. Each horizontal 
track represents a single sine wave. Color indicates the amplitude of the sine 
wave, vertical position indicates the frequency of the sine wave, and horizon
tal position indicates time. The spectrum editor uses the Capybara for real 
time auditioning of the resynthesis while editing.

The yellow scrub bar can be moved with the mouse, with MIDI pitch bend, or 
left or right arrow keys. While the scrub bar is moving, the resynthesis will play.

Markers indicate labeled time points and time segments for cutting or audi
tioning. The white marker is selected and its time position and label are dis
played at the top of the editor.

Click a marker to select it; the scrub bar moves to the marker time. Press 
Enter to rename the selected marker; use the Delete key or Cut from the 
Edit menu to remove the selected marker.

These buttons do the following: creates a marker at the scrub bar time; pla
ces the start marker at the scrub bar; places the end marker at the scrub 
bar; and sets pre- and post-roll play times.

These buttons do the following: play the entire spectrum; play the selection; 
play the selection between start and end markers; and play the selection out
side of start and end markers.

Information on the track under the cross hair cursor is displayed here.

Zero the amplitude of the selected tracks by choosing Clear from Edit menu. 
Grayed tracks have zeroed (cleared) amplitudes.

These buttons do the following: modify the selection in various ways; cut the 
time between the start and end markers; and switch in and out of drawing mode.

These buttons do the following: zoom the display all the way out; switch be
tween time-frequency and time-amplitude display modes; switch between iso
lated-dot and connected-dot between spectral frames; select tracks and 
frames based on various criteria.

Selected tracks are brighter. Select by clicking on an individual track, or by 
drawing a box around a region to select. Hold the Shift key while selecting to 
add to or remove from the current selection. Select a track between 1 and 10 
by pressing a number key (1-9, 0). Up and down arrow keys select next higher 
or lower track.

Create a Sound to play the selected part of the spectrum by choosing Copy 
from Edit menu, then Paste into a time line, Sound editor, or Sound file window.

Hold down the Control or Command key while drawing a box to zoom in on a 
specific region.

Kyma automatically displays comments from Annotation mod
ules in your Sound. You can also add text using the VCS editor.

Spectrum and waveform displays come from SpectrumAna
lyzer and OscilloscopeDisplay Sounds or by playing the Sound 
from Spectrum analyzer or Oscilloscope in the Info menu. 
The axes of the spectrum are linear frequency and dB magni
tude. The axes of the oscilloscope are time and amplitude.

Compress or expand the frequency, magnitude, time or am
plitude axes with these buttons.

All controls come from Event Values (hot variables) in the 
Sound (for instance, !ModIndex). An Event Value can be dis
played as a fader, potentiometer, or continuous rotary (with 
or without the text field), or as text, buttons, or switches.

To change the value of a fader, potentiometer, or rotary, use the 
mouse (hold Shift down for fine adjustments), or enter a number 
into the box above the control and press Enter. Tab cycles 
through the boxes. If a MIDI device is mapped to the controller 
(though the global map, a MIDIMapper Sound, or the VCS it
self), the controller can be adjusted using the MIDI device.

If a CM Automation Motor Mix is attached to the Capybara 
and selected in the Kyma preferences, it will automatically 
show abbreviations of the controller names displayed in its 
LCD scribble strip, and its faders, rotaries, and buttons will 
be mapped to control the VCS.

—  SOUND  FILE  WINDOW  —
A Sound file contains a collection of Sounds and Sound folders. Use Sound files to 
keep related Sounds together. Sounds can be dragged between this window and 
time lines, Sound editors, and other Sound file windows.

This Sound is selected. Click any Sound icon to select it. The Action and Info 
menu operations refer to this Sound. Press Enter to change the name of the 
Sound. Press Ctrl+Space to compile, load and start the selected Sound.

This Sound is being edited (see Sound editor). Double-click any Sound’s icon to 
edit its structure and parameters.

This is a Sound collection. Use Collect… from the Action menu to place the select
ed Sounds into a new collection.

—  STATUS FROM DSP MENU  —

—  SAMPLES FILE EDITOR  —

Time since currently playing Sound was 
started. Does not update after Sound 
ends or when DSP is stopped.

Last time code received via SMPTE LTC 
(L), SMPTE VITC (V), or MIDI time 
code (M).

Choose analog or digital audio interface 
for each input channel pair from the 
pull down list.

Choose either AES/EBU or S/PDIF as 
digital input and output format for 
groups of four inputs and outputs.

Status from the DSP menu displays audio levels and 
DSP usage in the Capybara. It also provides a way to 
configure the audio inputs and outputs.

Input peak level indicator. Click mouse to clear. Possible 
clipping if it shows >0< (meaning the signal reached 0 dB 
at some point). Output has a corresponding indicator.

Input and output level indicators. Lines indicate -10, -20, 
-40, -60, and -80 dB.

Approximate measure of current computational load on 
each DSP. Each line indicates approximately 20% usage.

Choose between internal and external sample rate clock 
sources from the pull down list.

Choose a sample rate from the pull down list.

Peak level in editing pane, and the 
duration, start, and end of the se
lection. Click to change units.

This is an overview of the entire 
file. Two channels are shown, even 
when editing single channel files.

This section is used to algorithmically generate waveforms. Use the 
triangle button to select a template from the list of templates. 
Modify the template parameters, and click Insert to evaluate the 
template and replace selection with the result.

The editing pane displays the portion of the file visible in the gray 
box in the overview. Click and drag in the overview, or use the scroll, 
expand, and compress buttons to navigate through the file.

The samples between these red lines are selected. Click and drag in 
this area to change the selection. Use Cut, Copy, Paste, Trim, and 
Clear selection in the Edit menu to alter the file. All changes in the 
editor are non-destructive; use Save or Save as… from the File 
menu to save the changes to the hard disk.

The gray box indicates the region of the file that is visible in the 
editing pane, below. Click and drag in this area to change the visible 
region. The red box indicates the current selection.

The buttons do the following: scroll one page to left; play selection; 
replace selection with a sample from disk; fit selection to window; 
compress time axis; expand time axis; compress level axis; expand 
level axis; additional options (including editing header information); 
and scroll one page to right.

Timing source, current time & time ruler

List of controllable parameters

Tracks and track settings

Control editor menus, info, transformations

Selected marker name & time; markers

Sounds with various durations & start times

Menus; selected Sound name, timing & color Transport controls, time line menus

Automated control of selected parameter

Time zoom-out, zoom-in, fit-window buttons

Value zoom-out and zoom-in buttons

Source of control: use pop-up menu to 
select a take, a MIDI controller, or 
another parameter from which the se-
lected parameter will get its values.

Type of control: use pop-up menu to 
choose whether the selected parame-
ter is automated, is controlled live, or 
is slaved to another parameter’s value.

Click to enable recording of 
the selected parameter when 
the time line is next played.

This parameter is selected.

The time and value of the first selected 
breakpoint. To move a point, enter its new 
time & value into these fields & press En-
ter, or click & drag it to the new location.

Click to apply a transformation 
to the control. Hold the mouse 
over any button for a descrip-
tion of its transformation.

Yellow time cursor indicates current time.

Dark background shows times 
when this control is active.

Automated control editor: click a breakpoint, draw a box, or Select all from Edit menu to select (Shift extends selection); Option or Ctrl 
& click to add; Delete key to delete; click & drag to move breakpoints (click, hold down Shift, then drag for vertical or horizontal move).

Click to choose audio input: a 
physical input, submix, or no 
input. The color-coded submix 
reverb is input for this track.

Pop-up menu to route track out-
put: directly to physical outputs; 
or via pan controls (Angle, Radius, 
Panner & Distance) and speaker 
locations (Preferences under 
Edit menu) to physical outputs.

Click to set track MIDI channel.

Click to solo; Option or Control 
& click to mute. Use Shift key 
to solo/mute multiple tracks.

Yellow dot is virtual source location

Click to send track output to 
a submix. Submix is assigned 
color & slot in grid.

Mic & MIDI are green when 
live, red when recording

Double-click a Sound to edit it. Edit-
ed Sounds are displayed in gray.

Drag this line up or down to 
adjust size of the track area.

The selected Sounds’ parameters.

Click a Sound, draw a box, or Select all from Edit menu to select (Shift extends 
selection); Delete key to delete; click & drag to change tracks or start time (click, 
hold down Shift, then drag for vertical or horizontal move); click & drag Sound 
end to change duration. Selected Sound parameters are displayed below on left. 

Drag & drop to add Sounds. Drag & drop onto 
a Sound to use it as the replacement input.

Click in the time ruler to send the 
yellow time cursor to that time.

The current time is displayed here. Enter a time & press 
Enter to move the yellow time cursor to a particular time.

Timing source: use pop-up menu to chase MIDI or SMPTE time 
code or MIDI timing clock; or to use an internal timing clock.

Click to select marker; drag marker to reposition it; Delete key removes marker.The selected marker’s name and time. Enter a new name or time and 
press Enter. Use Ctrl+L to 
enter spaces into the name.

Start time, anchor time, duration, & end time of selected Sound(s). Enter a time & press Enter.The selected Sound’s name and polyphony. Enter a new name or 
polyphony & press Enter. Use Ctrl+L to enter spaces into name. 
Polyphony is the number of voices for keyboard-based Sounds.

Set time grid mode (free, quantized, mag-
net); do time editing; choose time line colors.Set groups of controllers to live, 

automated, or record-enabled.

Play and pause (Space toggles, 
Ctrl+Æ plays, Ctrl+¨ rewinds & 
stops); go to prev & next marker, 
prev & next Sound; insert mark-
er, spaced markers, anchor.

Click a Sound’s tab (the small box attached to the left edge of the icon) to show 
hidden inputs. Clicking again will hide the inputs. Click and drag a Sound to reposi
tion it. Hold down the Shift key to move the Sound and its inputs at the same time.

Set bar division or frame rate 
and beat or frame subdivision.

Set time displays to bars 
and beats or time code.

Each Sound in the list that is preceded by a cyan arrow (Æ) performs processing on an input (the re
placeable input). These Sounds come with a default input, but a replacement input can be substituted 
for the default input, making it easy to quickly audition and create combinations of different process
ing algorithms and source material. The following controls set the replacement input to use with 
Sounds that take replaceable inputs:

Click this button to replace the Sound’s original input with the previously selected replacement input.

This is the name of the previously selected replacement input.

Click here to make the Sound or file selected in the list become the replacement input.

Click here to make the first audio input channel of the Capybara become the replacement input.

Click to update the list when files or directories have been added or removed by other programs.

Play and stop buttons for auditioning the selected Sound or file. (Cmd+Space and Cmd+K are shortcuts.)

Check a box to show a specific kind of file or Sound in the list. The categories are, from left to right, 
unknown file types, folders, text files, global maps, tools, compiled Sound grids, MIDI files, samples or 
digital recordings, spectral analysis files, RE resonator files, group additive synthesis files, Sound files, 
Sound collections within Sound files, Sounds within Sound collections or Sound files, and time lines.

—  SOUND  BROWSER  —

Sounds, files and folders are listed here in the same color as the check boxes (e.g., blue for Sounds). A 
Sound that has been changed but not yet saved is displayed with a yellow triangle to the left of the 
name. Choose Save from the File menu to save the changes made to all Sounds.

Click a file to select it. Double-click a Sound or file to edit it. Click the triangle next to a folder to 
show or hide its contents (hold Control or Command key down to also open all sub-folders). Double-click 
a folder to open a Sound Browser on that folder.

Use the arrow keys to move the selection up or down. Use Find… from the Action menu (Cmd+F) to se
lect a Sound or file by name. The Action and Info menus refer to the selection. Use Cmd+Space or the 
transport controls to audition the selection. Click and drag the selection into a time line, Sound editor, 
or Sound file window to use the selection in your work.

Information on the selected Sound, file or folder.
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—  TIME  LINE  — —  SOUND  EDITOR  —

—  VIRTUAL  CONTROL  SURFACE  —

The prototypes are categorized by function or technique. 
Clicking on a category name here changes the list of proto
types that appears at the right.

—  SYSTEM  PROTOTYPES  —

Select a prototype by clicking on its icon, or choose Find pro
totype… from the Action menu (Cmd+B) anywhere in Kyma to 
search for a prototype by name. This prototype is selected. 
The Action and Info menus refer to this Sound. Press the 
Control or Command key along with Space Bar (Cmd+Space) to compile, load and start (or play) this proto
type. Click and drag the prototype into a time line, Sound editor, or Sound file window to use it in your work.

—  STATUS FROM FILE MENU  —
Indicates the amount of memory Kyma is using on your computer. Leave this window open so that Kyma 
can do memory recycling automatically for you. Click Recycle if the meter goes into the red. 

Displays the name of the global map file currently in use. The global map associates memorable control
ler names, like !DutyCycle, with real MIDI channels and controller numbers.

Shows the inputs expected by the Sound currently playing: audio, MIDI controllers, and/or MIDI key
board.

—  SPECTRUM  EDITOR  —

Double-click a Sound to edit 
its parameters. The edited 
Sound’s parameters are shown 
at the bottom of the window, 
and its icon is grayed out.

Click a Sound to select it. Use 
Cmd+Space to audition the se-
lected Sound, Enter to change 
its name. The Action and Info 
menus refer to this Sound. 

A cyan halo surrounds the replaceable input. The replaceable input 
Sound is replaced when you drag the Sound being edited onto another 
Sound in the time line or onto a line in a Sound editor, or use it with a re-
placement input in the Sound browser. To set the replaceable input, se-
lect a Sound and choose Set replaceable input from the Action menu.

The Sound editor shows the signal flow between Sounds and the parameters of 
those Sounds.

Double-clicking a Sound in the time line or Sound file window opens the Sound ed-
itor on a copy of that Sound. The changes you make in the Sound editor are not 
saved back into the time line or Sound file window until the Sound editor is 
closed. Use Save from the File menu to save back the changes without closing the 
editor window.

These are the parameters of the Sound double-clicked in the signal flow diagram.

A parameter with a cyan background and italic name is a hot parameter. Hot param-
eters can be controlled by any combination of constant values, values from MIDI or 
on-screen controllers, the output of another Sound, or arithmetic expressions.

A parameter with a white background and non-italicized name is a constant pa-
rameter. A constant parameter has a fixed value for the duration of the Sound.

The top part of the editor is the signal flow diagram. A stereo signal travels along 
each line from left to right. A thick line with a number in a box indicates that a 
signal is used more than once in the destination module (as in the lower window).

To insert a Sound into the signal flow, drag the Sound onto a line connecting two 
Sounds. To delete a Sound, click on its icon to select it, then press Delete. To replace 
a Sound with a copy of another Sound, drag the other Sound on top of the Sound to 
be replaced. To route the same Sound to two or more places, hold down Control or 
Option while dragging. Alternatively, use Paste or Paste special… from the Edit menu.

Drag this line up or down to adjust the size of the parameter area. To expand to 
the maximum size, double click in the background of the parameter area.

This is the type of the Sound 
being edited. Hold the mouse 
over this area for a descrip-
tion of the Sound type.

This is the name of one of the 
Sound’s parameters. Hold the 
mouse over the name for a de-
scription of the parameter.

Signal inputs to a Sound appear in both the signal flow diagram and in the Sound’s 
parameters. To change the input, cut, copy, paste, or drag Sounds into the param-
eter field, or onto the icon of the old input in the signal flow diagram. The signal 
flow diagram will not be updated until you double-click a different Sound or dou-
ble-click in the background of the signal flow diagram.

Can’t remember what arithmetic can be used in parame-
ter fields? Ctrl+Shift+H lets you choose from a list.

Can’t see everything in a field? Use Large window… from 
the Edit menu (Ctrl+L) to expand it to full screen size.

If a field flashes when you play the Sound, it indicates 
an error in the field’s value.

Parameters can be controlled by Sounds acting as 
LFOs. To insert a Sound into a hot parameter field, 
Copy the Sound, and then Paste it into the field. Use 
L for left, R for right, or M for mono mix.

Hot parameter fields can contain Event Values control-
led by MIDI or the Virtual Control Surface. Event Val-
ues can be inserted by hitting the Escape key and mov-
ing a MIDI controller or playing the MIDI keyboard 
(one key for !KeyPitch, two keys for !KeyDown, three 
keys for !KeyVelocity), choosing Paste hot… from the 
Edit menu, or by typing ! followed by any name.

Click this button to choose a file from a standard file 
dialog. Use Shift+click to get information about the 
current file. Use Control+click or Command+click to 
open an editor on the current file.

The virtual control surface (VCS) is a control panel or user 
interface for the currently playing Sound. It stores control 
settings in presets and alternative graphical arrangements 
of the controller widgets in layouts.

The top part of the VCS contains controls for selecting and 
editing presets and layouts. The bottom portion contains 
the graphical controls for interacting with the Sound.

Click the triangle to choose a preset from 
a list. Click the camera (or click the name 
and press Enter) to take a snapshot of 
the current settings.

Click the dice to set controllers randomly. 
Click a controller label (making it gray) to 
keep the dice from changing that controller.

These are the layout controls. Click the 
triangle to choose the controller layout 
from a list of predefined layouts.

Click the padlock to unlock/lock the 
VCS. When unlocked, the MIDI map
ping, type, range, and location of the 
controllers can be edited (see below).

Clicking the padlock at the upper right corner of the virtual 
control surface unlocks the layout and opens the VCS editor.

The upper portion of the editor displays a list of layouts for 
the currently playing Sound. Click to select one or Shift+click 
to select several layouts. The buttons below the list open 
pop-up menus for adding, merging and removing layouts (Lay
out…); arranging the selected controller widgets (Arrange…); 
and adding and removing controller widgets (Options…).

The lower portion of the editor provides a way to edit the se
lected controller widget(s): its MIDI channel and controller 
number, its label, its type (fader, button, etc.), whether it has 
an associated number field, its taper (linear or log), its mini
mum, maximum and gridding values, and its screen location.

Select widgets by clicking in the VCS window (hold down Shift key to 
extend the selection), drawing a box around a group (hold down Com
mand or Control to start within a widget), or by selecting a name using 
Selected Value in the editor.

To quickly assign a MIDI controller to a widget, select the widget, 
press the Escape key, and move the controller.

Click & drag a corner or edge of a widget to resize it; click & drag 
from the center to move it. Click, press the Shift key, then drag to 
move only vertically or horizontally. While resizing or moving a widg
et, the edges of other widgets act as snap-to guides to aid placement.

The spectrum editor displays the amplitude and frequency envelopes of sine 
wave components to be used during additive resynthesis. Each horizontal 
track represents a single sine wave. Color indicates the amplitude of the sine 
wave, vertical position indicates the frequency of the sine wave, and horizon
tal position indicates time. The spectrum editor uses the Capybara for real 
time auditioning of the resynthesis while editing.

The yellow scrub bar can be moved with the mouse, with MIDI pitch bend, or 
left or right arrow keys. While the scrub bar is moving, the resynthesis will play.

Markers indicate labeled time points and time segments for cutting or audi
tioning. The white marker is selected and its time position and label are dis
played at the top of the editor.

Click a marker to select it; the scrub bar moves to the marker time. Press 
Enter to rename the selected marker; use the Delete key or Cut from the 
Edit menu to remove the selected marker.

These buttons do the following: creates a marker at the scrub bar time; pla
ces the start marker at the scrub bar; places the end marker at the scrub 
bar; and sets pre- and post-roll play times.

These buttons do the following: play the entire spectrum; play the selection; 
play the selection between start and end markers; and play the selection out
side of start and end markers.

Information on the track under the cross hair cursor is displayed here.

Zero the amplitude of the selected tracks by choosing Clear from Edit menu. 
Grayed tracks have zeroed (cleared) amplitudes.

These buttons do the following: modify the selection in various ways; cut the 
time between the start and end markers; and switch in and out of drawing mode.

These buttons do the following: zoom the display all the way out; switch be
tween time-frequency and time-amplitude display modes; switch between iso
lated-dot and connected-dot between spectral frames; select tracks and 
frames based on various criteria.

Selected tracks are brighter. Select by clicking on an individual track, or by 
drawing a box around a region to select. Hold the Shift key while selecting to 
add to or remove from the current selection. Select a track between 1 and 10 
by pressing a number key (1-9, 0). Up and down arrow keys select next higher 
or lower track.

Create a Sound to play the selected part of the spectrum by choosing Copy 
from Edit menu, then Paste into a time line, Sound editor, or Sound file window.

Hold down the Control or Command key while drawing a box to zoom in on a 
specific region.

Kyma automatically displays comments from Annotation mod
ules in your Sound. You can also add text using the VCS editor.

Spectrum and waveform displays come from SpectrumAna
lyzer and OscilloscopeDisplay Sounds or by playing the Sound 
from Spectrum analyzer or Oscilloscope in the Info menu. 
The axes of the spectrum are linear frequency and dB magni
tude. The axes of the oscilloscope are time and amplitude.

Compress or expand the frequency, magnitude, time or am
plitude axes with these buttons.

All controls come from Event Values (hot variables) in the 
Sound (for instance, !ModIndex). An Event Value can be dis
played as a fader, potentiometer, or continuous rotary (with 
or without the text field), or as text, buttons, or switches.

To change the value of a fader, potentiometer, or rotary, use the 
mouse (hold Shift down for fine adjustments), or enter a number 
into the box above the control and press Enter. Tab cycles 
through the boxes. If a MIDI device is mapped to the controller 
(though the global map, a MIDIMapper Sound, or the VCS it
self), the controller can be adjusted using the MIDI device.

If a CM Automation Motor Mix is attached to the Capybara 
and selected in the Kyma preferences, it will automatically 
show abbreviations of the controller names displayed in its 
LCD scribble strip, and its faders, rotaries, and buttons will 
be mapped to control the VCS.

—  SOUND  FILE  WINDOW  —
A Sound file contains a collection of Sounds and Sound folders. Use Sound files to 
keep related Sounds together. Sounds can be dragged between this window and 
time lines, Sound editors, and other Sound file windows.

This Sound is selected. Click any Sound icon to select it. The Action and Info 
menu operations refer to this Sound. Press Enter to change the name of the 
Sound. Press Ctrl+Space to compile, load and start the selected Sound.

This Sound is being edited (see Sound editor). Double-click any Sound’s icon to 
edit its structure and parameters.

This is a Sound collection. Use Collect… from the Action menu to place the select
ed Sounds into a new collection.

—  STATUS FROM DSP MENU  —

—  SAMPLES FILE EDITOR  —

Time since currently playing Sound was 
started. Does not update after Sound 
ends or when DSP is stopped.

Last time code received via SMPTE LTC 
(L), SMPTE VITC (V), or MIDI time 
code (M).

Choose analog or digital audio interface 
for each input channel pair from the 
pull down list.

Choose either AES/EBU or S/PDIF as 
digital input and output format for 
groups of four inputs and outputs.

Status from the DSP menu displays audio levels and 
DSP usage in the Capybara. It also provides a way to 
configure the audio inputs and outputs.

Input peak level indicator. Click mouse to clear. Possible 
clipping if it shows >0< (meaning the signal reached 0 dB 
at some point). Output has a corresponding indicator.

Input and output level indicators. Lines indicate -10, -20, 
-40, -60, and -80 dB.

Approximate measure of current computational load on 
each DSP. Each line indicates approximately 20% usage.

Choose between internal and external sample rate clock 
sources from the pull down list.

Choose a sample rate from the pull down list.

Peak level in editing pane, and the 
duration, start, and end of the se
lection. Click to change units.

This is an overview of the entire 
file. Two channels are shown, even 
when editing single channel files.

This section is used to algorithmically generate waveforms. Use the 
triangle button to select a template from the list of templates. 
Modify the template parameters, and click Insert to evaluate the 
template and replace selection with the result.

The editing pane displays the portion of the file visible in the gray 
box in the overview. Click and drag in the overview, or use the scroll, 
expand, and compress buttons to navigate through the file.

The samples between these red lines are selected. Click and drag in 
this area to change the selection. Use Cut, Copy, Paste, Trim, and 
Clear selection in the Edit menu to alter the file. All changes in the 
editor are non-destructive; use Save or Save as… from the File 
menu to save the changes to the hard disk.

The gray box indicates the region of the file that is visible in the 
editing pane, below. Click and drag in this area to change the visible 
region. The red box indicates the current selection.

The buttons do the following: scroll one page to left; play selection; 
replace selection with a sample from disk; fit selection to window; 
compress time axis; expand time axis; compress level axis; expand 
level axis; additional options (including editing header information); 
and scroll one page to right.

Timing source, current time & time ruler

List of controllable parameters

Tracks and track settings

Control editor menus, info, transformations

Selected marker name & time; markers

Sounds with various durations & start times

Menus; selected Sound name, timing & color Transport controls, time line menus

Automated control of selected parameter

Time zoom-out, zoom-in, fit-window buttons

Value zoom-out and zoom-in buttons

Source of control: use pop-up menu to 
select a take, a MIDI controller, or 
another parameter from which the se
lected parameter will get its values.

Type of control: use pop-up menu to 
choose whether the selected parame
ter is automated, is controlled live, or 
is slaved to another parameter’s value.

Click to enable recording of 
the selected parameter when 
the time line is next played.

This parameter is selected.

The time and value of the first selected 
breakpoint. To move a point, enter its new 
time & value into these fields & press En
ter, or click & drag it to the new location.

Click to apply a transformation 
to the control. Hold the mouse 
over any button for a descrip
tion of its transformation.

Yellow time cursor indicates current time.

Dark background shows times 
when this control is active.

Automated control editor: click a breakpoint, draw a box, or Select all from Edit menu to select (Shift extends selection); Option or Ctrl 
& click to add; Delete key to delete; click & drag to move breakpoints (click, hold down Shift, then drag for vertical or horizontal move).

Click to choose audio input: a 
physical input, submix, or no 
input. The color-coded submix 
reverb is input for this track.

Pop-up menu to route track out
put: directly to physical outputs; 
or via pan controls (Angle, Radius, 
Panner & Distance) and speaker 
locations (Preferences under 
Edit menu) to physical outputs.

Click to set track MIDI channel.

Click to solo; Option or Control 
& click to mute. Use Shift key 
to solo/mute multiple tracks.

Yellow dot is virtual source location

Click to send track output to 
a submix. Submix is assigned 
color & slot in grid.

Mic & MIDI are green when 
live, red when recording

Double-click a Sound to edit it. Edit
ed Sounds are displayed in gray.

Drag this line up or down to 
adjust size of the track area.

The selected Sounds’ parameters.

Click a Sound, draw a box, or Select all from Edit menu to select (Shift extends 
selection); Delete key to delete; click & drag to change tracks or start time (click, 
hold down Shift, then drag for vertical or horizontal move); click & drag Sound 
end to change duration. Selected Sound parameters are displayed below on left. 

Drag & drop to add Sounds. Drag & drop onto 
a Sound to use it as the replacement input.

Click in the time ruler to send the 
yellow time cursor to that time.

The current time is displayed here. Enter a time & press 
Enter to move the yellow time cursor to a particular time.

Timing source: use pop-up menu to chase MIDI or SMPTE time 
code or MIDI timing clock; or to use an internal timing clock.

Click to select marker; drag marker to reposition it; Delete key removes marker.The selected marker’s name and time. Enter a new name or time and 
press Enter. Use Ctrl+L to 
enter spaces into the name.

Start time, anchor time, duration, & end time of selected Sound(s). Enter a time & press Enter.The selected Sound’s name and polyphony. Enter a new name or 
polyphony & press Enter. Use Ctrl+L to enter spaces into name. 
Polyphony is the number of voices for keyboard-based Sounds.

Set time grid mode (free, quantized, mag
net); do time editing; choose time line colors.Set groups of controllers to live, 

automated, or record-enabled.

Play and pause (Space toggles, 
Ctrl+Æ plays, Ctrl+¨ rewinds & 
stops); go to prev & next marker, 
prev & next Sound; insert mark
er, spaced markers, anchor.

Click a Sound’s tab (the small box attached to the left edge of the icon) to show 
hidden inputs. Clicking again will hide the inputs. Click and drag a Sound to reposi-
tion it. Hold down the Shift key to move the Sound and its inputs at the same time.

Set bar division or frame rate 
and beat or frame subdivision.

Set time displays to bars 
and beats or time code.

Each Sound in the list that is preceded by a cyan arrow (Æ) performs processing on an input (the re
placeable input). These Sounds come with a default input, but a replacement input can be substituted 
for the default input, making it easy to quickly audition and create combinations of different process
ing algorithms and source material. The following controls set the replacement input to use with 
Sounds that take replaceable inputs:

Click this button to replace the Sound’s original input with the previously selected replacement input.

This is the name of the previously selected replacement input.

Click here to make the Sound or file selected in the list become the replacement input.

Click here to make the first audio input channel of the Capybara become the replacement input.

Click to update the list when files or directories have been added or removed by other programs.

Play and stop buttons for auditioning the selected Sound or file. (Cmd+Space and Cmd+K are shortcuts.)

Check a box to show a specific kind of file or Sound in the list. The categories are, from left to right, 
unknown file types, folders, text files, global maps, tools, compiled Sound grids, MIDI files, samples or 
digital recordings, spectral analysis files, RE resonator files, group additive synthesis files, Sound files, 
Sound collections within Sound files, Sounds within Sound collections or Sound files, and time lines.

—  SOUND  BROWSER  —

Sounds, files and folders are listed here in the same color as the check boxes (e.g., blue for Sounds). A 
Sound that has been changed but not yet saved is displayed with a yellow triangle to the left of the 
name. Choose Save from the File menu to save the changes made to all Sounds.

Click a file to select it. Double-click a Sound or file to edit it. Click the triangle next to a folder to 
show or hide its contents (hold Control or Command key down to also open all sub-folders). Double-click 
a folder to open a Sound Browser on that folder.

Use the arrow keys to move the selection up or down. Use Find… from the Action menu (Cmd+F) to se
lect a Sound or file by name. The Action and Info menus refer to the selection. Use Cmd+Space or the 
transport controls to audition the selection. Click and drag the selection into a time line, Sound editor, 
or Sound file window to use the selection in your work.

Information on the selected Sound, file or folder.

©Copyright 2000 by the Symbolic Sound Corporation. All rights reserved.
Symbolic Sound, Kyma, and Capybara are trademarks of the Symbolic Sound Corporation.

Symbolic Sound Corporation * Post Office Box 2530 * Champaign, Illinois 61825-2530 * United States of America
Tel:+217-355-6273 * Fax:+217-355-6562 * info-kyma@SymbolicSound.com * http://www.SymbolicSound.com



—  TIME  LINE  — —  SOUND  EDITOR  —

—  VIRTUAL  CONTROL  SURFACE  —

The prototypes are categorized by function or technique. 
Clicking on a category name here changes the list of proto
types that appears at the right.

—  SYSTEM  PROTOTYPES  —

Select a prototype by clicking on its icon, or choose Find pro
totype… from the Action menu (Cmd+B) anywhere in Kyma to 
search for a prototype by name. This prototype is selected. 
The Action and Info menus refer to this Sound. Press the 
Control or Command key along with Space Bar (Cmd+Space) to compile, load and start (or play) this proto
type. Click and drag the prototype into a time line, Sound editor, or Sound file window to use it in your work.

—  STATUS FROM FILE MENU  —
Indicates the amount of memory Kyma is using on your computer. Leave this window open so that Kyma 
can do memory recycling automatically for you. Click Recycle if the meter goes into the red. 

Displays the name of the global map file currently in use. The global map associates memorable control-
ler names, like !DutyCycle, with real MIDI channels and controller numbers.

Shows the inputs expected by the Sound currently playing: audio, MIDI controllers, and/or MIDI key-
board.

—  SPECTRUM  EDITOR  —

Double-click a Sound to edit 
its parameters. The edited 
Sound’s parameters are shown 
at the bottom of the window, 
and its icon is grayed out.

Click a Sound to select it. Use 
Cmd+Space to audition the se
lected Sound, Enter to change 
its name. The Action and Info 
menus refer to this Sound. 

A cyan halo surrounds the replaceable input. The replaceable input 
Sound is replaced when you drag the Sound being edited onto another 
Sound in the time line or onto a line in a Sound editor, or use it with a re
placement input in the Sound browser. To set the replaceable input, se
lect a Sound and choose Set replaceable input from the Action menu.

The Sound editor shows the signal flow between Sounds and the parameters of 
those Sounds.

Double-clicking a Sound in the time line or Sound file window opens the Sound ed
itor on a copy of that Sound. The changes you make in the Sound editor are not 
saved back into the time line or Sound file window until the Sound editor is 
closed. Use Save from the File menu to save back the changes without closing the 
editor window.

These are the parameters of the Sound double-clicked in the signal flow diagram.

A parameter with a cyan background and italic name is a hot parameter. Hot param
eters can be controlled by any combination of constant values, values from MIDI or 
on-screen controllers, the output of another Sound, or arithmetic expressions.

A parameter with a white background and non-italicized name is a constant pa
rameter. A constant parameter has a fixed value for the duration of the Sound.

The top part of the editor is the signal flow diagram. A stereo signal travels along 
each line from left to right. A thick line with a number in a box indicates that a 
signal is used more than once in the destination module (as in the lower window).

To insert a Sound into the signal flow, drag the Sound onto a line connecting two 
Sounds. To delete a Sound, click on its icon to select it, then press Delete. To replace 
a Sound with a copy of another Sound, drag the other Sound on top of the Sound to 
be replaced. To route the same Sound to two or more places, hold down Control or 
Option while dragging. Alternatively, use Paste or Paste special… from the Edit menu.

Drag this line up or down to adjust the size of the parameter area. To expand to 
the maximum size, double click in the background of the parameter area.

This is the type of the Sound 
being edited. Hold the mouse 
over this area for a descrip
tion of the Sound type.

This is the name of one of the 
Sound’s parameters. Hold the 
mouse over the name for a de
scription of the parameter.

Signal inputs to a Sound appear in both the signal flow diagram and in the Sound’s 
parameters. To change the input, cut, copy, paste, or drag Sounds into the param
eter field, or onto the icon of the old input in the signal flow diagram. The signal 
flow diagram will not be updated until you double-click a different Sound or dou
ble-click in the background of the signal flow diagram.

Can’t remember what arithmetic can be used in parame
ter fields? Ctrl+Shift+H lets you choose from a list.

Can’t see everything in a field? Use Large window… from 
the Edit menu (Ctrl+L) to expand it to full screen size.

If a field flashes when you play the Sound, it indicates 
an error in the field’s value.

Parameters can be controlled by Sounds acting as 
LFOs. To insert a Sound into a hot parameter field, 
Copy the Sound, and then Paste it into the field. Use 
L for left, R for right, or M for mono mix.

Hot parameter fields can contain Event Values control
led by MIDI or the Virtual Control Surface. Event Val
ues can be inserted by hitting the Escape key and mov
ing a MIDI controller or playing the MIDI keyboard 
(one key for !KeyPitch, two keys for !KeyDown, three 
keys for !KeyVelocity), choosing Paste hot… from the 
Edit menu, or by typing ! followed by any name.

Click this button to choose a file from a standard file 
dialog. Use Shift+click to get information about the 
current file. Use Control+click or Command+click to 
open an editor on the current file.

The virtual control surface (VCS) is a control panel or user 
interface for the currently playing Sound. It stores control 
settings in presets and alternative graphical arrangements 
of the controller widgets in layouts.

The top part of the VCS contains controls for selecting and 
editing presets and layouts. The bottom portion contains 
the graphical controls for interacting with the Sound.

Click the triangle to choose a preset from 
a list. Click the camera (or click the name 
and press Enter) to take a snapshot of 
the current settings.

Click the dice to set controllers randomly. 
Click a controller label (making it gray) to 
keep the dice from changing that controller.

These are the layout controls. Click the 
triangle to choose the controller layout 
from a list of predefined layouts.

Click the padlock to unlock/lock the 
VCS. When unlocked, the MIDI map
ping, type, range, and location of the 
controllers can be edited (see below).

Clicking the padlock at the upper right corner of the virtual 
control surface unlocks the layout and opens the VCS editor.

The upper portion of the editor displays a list of layouts for 
the currently playing Sound. Click to select one or Shift+click 
to select several layouts. The buttons below the list open 
pop-up menus for adding, merging and removing layouts (Lay
out…); arranging the selected controller widgets (Arrange…); 
and adding and removing controller widgets (Options…).

The lower portion of the editor provides a way to edit the se
lected controller widget(s): its MIDI channel and controller 
number, its label, its type (fader, button, etc.), whether it has 
an associated number field, its taper (linear or log), its mini
mum, maximum and gridding values, and its screen location.

Select widgets by clicking in the VCS window (hold down Shift key to 
extend the selection), drawing a box around a group (hold down Com
mand or Control to start within a widget), or by selecting a name using 
Selected Value in the editor.

To quickly assign a MIDI controller to a widget, select the widget, 
press the Escape key, and move the controller.

Click & drag a corner or edge of a widget to resize it; click & drag 
from the center to move it. Click, press the Shift key, then drag to 
move only vertically or horizontally. While resizing or moving a widg
et, the edges of other widgets act as snap-to guides to aid placement.

The spectrum editor displays the amplitude and frequency envelopes of sine 
wave components to be used during additive resynthesis. Each horizontal 
track represents a single sine wave. Color indicates the amplitude of the sine 
wave, vertical position indicates the frequency of the sine wave, and horizon
tal position indicates time. The spectrum editor uses the Capybara for real 
time auditioning of the resynthesis while editing.

The yellow scrub bar can be moved with the mouse, with MIDI pitch bend, or 
left or right arrow keys. While the scrub bar is moving, the resynthesis will play.

Markers indicate labeled time points and time segments for cutting or audi
tioning. The white marker is selected and its time position and label are dis
played at the top of the editor.

Click a marker to select it; the scrub bar moves to the marker time. Press 
Enter to rename the selected marker; use the Delete key or Cut from the 
Edit menu to remove the selected marker.

These buttons do the following: creates a marker at the scrub bar time; pla
ces the start marker at the scrub bar; places the end marker at the scrub 
bar; and sets pre- and post-roll play times.

These buttons do the following: play the entire spectrum; play the selection; 
play the selection between start and end markers; and play the selection out
side of start and end markers.

Information on the track under the cross hair cursor is displayed here.

Zero the amplitude of the selected tracks by choosing Clear from Edit menu. 
Grayed tracks have zeroed (cleared) amplitudes.

These buttons do the following: modify the selection in various ways; cut the 
time between the start and end markers; and switch in and out of drawing mode.

These buttons do the following: zoom the display all the way out; switch be
tween time-frequency and time-amplitude display modes; switch between iso
lated-dot and connected-dot between spectral frames; select tracks and 
frames based on various criteria.

Selected tracks are brighter. Select by clicking on an individual track, or by 
drawing a box around a region to select. Hold the Shift key while selecting to 
add to or remove from the current selection. Select a track between 1 and 10 
by pressing a number key (1-9, 0). Up and down arrow keys select next higher 
or lower track.

Create a Sound to play the selected part of the spectrum by choosing Copy 
from Edit menu, then Paste into a time line, Sound editor, or Sound file window.

Hold down the Control or Command key while drawing a box to zoom in on a 
specific region.

Kyma automatically displays comments from Annotation mod
ules in your Sound. You can also add text using the VCS editor.

Spectrum and waveform displays come from SpectrumAna
lyzer and OscilloscopeDisplay Sounds or by playing the Sound 
from Spectrum analyzer or Oscilloscope in the Info menu. 
The axes of the spectrum are linear frequency and dB magni
tude. The axes of the oscilloscope are time and amplitude.

Compress or expand the frequency, magnitude, time or am
plitude axes with these buttons.

All controls come from Event Values (hot variables) in the 
Sound (for instance, !ModIndex). An Event Value can be dis
played as a fader, potentiometer, or continuous rotary (with 
or without the text field), or as text, buttons, or switches.

To change the value of a fader, potentiometer, or rotary, use the 
mouse (hold Shift down for fine adjustments), or enter a number 
into the box above the control and press Enter. Tab cycles 
through the boxes. If a MIDI device is mapped to the controller 
(though the global map, a MIDIMapper Sound, or the VCS it
self), the controller can be adjusted using the MIDI device.

If a CM Automation Motor Mix is attached to the Capybara 
and selected in the Kyma preferences, it will automatically 
show abbreviations of the controller names displayed in its 
LCD scribble strip, and its faders, rotaries, and buttons will 
be mapped to control the VCS.

—  SOUND  FILE  WINDOW  —
A Sound file contains a collection of Sounds and Sound folders. Use Sound files to 
keep related Sounds together. Sounds can be dragged between this window and 
time lines, Sound editors, and other Sound file windows.

This Sound is selected. Click any Sound icon to select it. The Action and Info 
menu operations refer to this Sound. Press Enter to change the name of the 
Sound. Press Ctrl+Space to compile, load and start the selected Sound.

This Sound is being edited (see Sound editor). Double-click any Sound’s icon to 
edit its structure and parameters.

This is a Sound collection. Use Collect… from the Action menu to place the select
ed Sounds into a new collection.

—  STATUS FROM DSP MENU  —

—  SAMPLES FILE EDITOR  —

Time since currently playing Sound was 
started. Does not update after Sound 
ends or when DSP is stopped.

Last time code received via SMPTE LTC 
(L), SMPTE VITC (V), or MIDI time 
code (M).

Choose analog or digital audio interface 
for each input channel pair from the 
pull down list.

Choose either AES/EBU or S/PDIF as 
digital input and output format for 
groups of four inputs and outputs.

Status from the DSP menu displays audio levels and 
DSP usage in the Capybara. It also provides a way to 
configure the audio inputs and outputs.

Input peak level indicator. Click mouse to clear. Possible 
clipping if it shows >0< (meaning the signal reached 0 dB 
at some point). Output has a corresponding indicator.

Input and output level indicators. Lines indicate -10, -20, 
-40, -60, and -80 dB.

Approximate measure of current computational load on 
each DSP. Each line indicates approximately 20% usage.

Choose between internal and external sample rate clock 
sources from the pull down list.

Choose a sample rate from the pull down list.

Peak level in editing pane, and the 
duration, start, and end of the se-
lection. Click to change units.

This is an overview of the entire 
file. Two channels are shown, even 
when editing single channel files.

This section is used to algorithmically generate waveforms. Use the 
triangle button to select a template from the list of templates. 
Modify the template parameters, and click Insert to evaluate the 
template and replace selection with the result.

The editing pane displays the portion of the file visible in the gray 
box in the overview. Click and drag in the overview, or use the scroll, 
expand, and compress buttons to navigate through the file.

The samples between these red lines are selected. Click and drag in 
this area to change the selection. Use Cut, Copy, Paste, Trim, and 
Clear selection in the Edit menu to alter the file. All changes in the 
editor are non-destructive; use Save or Save as… from the File 
menu to save the changes to the hard disk.

The gray box indicates the region of the file that is visible in the 
editing pane, below. Click and drag in this area to change the visible 
region. The red box indicates the current selection.

The buttons do the following: scroll one page to left; play selection; 
replace selection with a sample from disk; fit selection to window; 
compress time axis; expand time axis; compress level axis; expand 
level axis; additional options (including editing header information); 
and scroll one page to right.

Timing source, current time & time ruler

List of controllable parameters

Tracks and track settings

Control editor menus, info, transformations

Selected marker name & time; markers

Sounds with various durations & start times

Menus; selected Sound name, timing & color Transport controls, time line menus

Automated control of selected parameter

Time zoom-out, zoom-in, fit-window buttons

Value zoom-out and zoom-in buttons

Source of control: use pop-up menu to 
select a take, a MIDI controller, or 
another parameter from which the se
lected parameter will get its values.

Type of control: use pop-up menu to 
choose whether the selected parame
ter is automated, is controlled live, or 
is slaved to another parameter’s value.

Click to enable recording of 
the selected parameter when 
the time line is next played.

This parameter is selected.

The time and value of the first selected 
breakpoint. To move a point, enter its new 
time & value into these fields & press En
ter, or click & drag it to the new location.

Click to apply a transformation 
to the control. Hold the mouse 
over any button for a descrip
tion of its transformation.

Yellow time cursor indicates current time.

Dark background shows times 
when this control is active.

Automated control editor: click a breakpoint, draw a box, or Select all from Edit menu to select (Shift extends selection); Option or Ctrl 
& click to add; Delete key to delete; click & drag to move breakpoints (click, hold down Shift, then drag for vertical or horizontal move).

Click to choose audio input: a 
physical input, submix, or no 
input. The color-coded submix 
reverb is input for this track.

Pop-up menu to route track out
put: directly to physical outputs; 
or via pan controls (Angle, Radius, 
Panner & Distance) and speaker 
locations (Preferences under 
Edit menu) to physical outputs.

Click to set track MIDI channel.

Click to solo; Option or Control 
& click to mute. Use Shift key 
to solo/mute multiple tracks.

Yellow dot is virtual source location

Click to send track output to 
a submix. Submix is assigned 
color & slot in grid.

Mic & MIDI are green when 
live, red when recording

Double-click a Sound to edit it. Edit
ed Sounds are displayed in gray.

Drag this line up or down to 
adjust size of the track area.

The selected Sounds’ parameters.

Click a Sound, draw a box, or Select all from Edit menu to select (Shift extends 
selection); Delete key to delete; click & drag to change tracks or start time (click, 
hold down Shift, then drag for vertical or horizontal move); click & drag Sound 
end to change duration. Selected Sound parameters are displayed below on left. 

Drag & drop to add Sounds. Drag & drop onto 
a Sound to use it as the replacement input.

Click in the time ruler to send the 
yellow time cursor to that time.

The current time is displayed here. Enter a time & press 
Enter to move the yellow time cursor to a particular time.

Timing source: use pop-up menu to chase MIDI or SMPTE time 
code or MIDI timing clock; or to use an internal timing clock.

Click to select marker; drag marker to reposition it; Delete key removes marker.The selected marker’s name and time. Enter a new name or time and 
press Enter. Use Ctrl+L to 
enter spaces into the name.

Start time, anchor time, duration, & end time of selected Sound(s). Enter a time & press Enter.The selected Sound’s name and polyphony. Enter a new name or 
polyphony & press Enter. Use Ctrl+L to enter spaces into name. 
Polyphony is the number of voices for keyboard-based Sounds.

Set time grid mode (free, quantized, mag
net); do time editing; choose time line colors.Set groups of controllers to live, 

automated, or record-enabled.

Play and pause (Space toggles, 
Ctrl+Æ plays, Ctrl+¨ rewinds & 
stops); go to prev & next marker, 
prev & next Sound; insert mark
er, spaced markers, anchor.

Click a Sound’s tab (the small box attached to the left edge of the icon) to show 
hidden inputs. Clicking again will hide the inputs. Click and drag a Sound to reposi
tion it. Hold down the Shift key to move the Sound and its inputs at the same time.

Set bar division or frame rate 
and beat or frame subdivision.

Set time displays to bars 
and beats or time code.

Each Sound in the list that is preceded by a cyan arrow (Æ) performs processing on an input (the re
placeable input). These Sounds come with a default input, but a replacement input can be substituted 
for the default input, making it easy to quickly audition and create combinations of different process
ing algorithms and source material. The following controls set the replacement input to use with 
Sounds that take replaceable inputs:

Click this button to replace the Sound’s original input with the previously selected replacement input.

This is the name of the previously selected replacement input.

Click here to make the Sound or file selected in the list become the replacement input.

Click here to make the first audio input channel of the Capybara become the replacement input.

Click to update the list when files or directories have been added or removed by other programs.

Play and stop buttons for auditioning the selected Sound or file. (Cmd+Space and Cmd+K are shortcuts.)

Check a box to show a specific kind of file or Sound in the list. The categories are, from left to right, 
unknown file types, folders, text files, global maps, tools, compiled Sound grids, MIDI files, samples or 
digital recordings, spectral analysis files, RE resonator files, group additive synthesis files, Sound files, 
Sound collections within Sound files, Sounds within Sound collections or Sound files, and time lines.

—  SOUND  BROWSER  —

Sounds, files and folders are listed here in the same color as the check boxes (e.g., blue for Sounds). A 
Sound that has been changed but not yet saved is displayed with a yellow triangle to the left of the 
name. Choose Save from the File menu to save the changes made to all Sounds.

Click a file to select it. Double-click a Sound or file to edit it. Click the triangle next to a folder to 
show or hide its contents (hold Control or Command key down to also open all sub-folders). Double-click 
a folder to open a Sound Browser on that folder.

Use the arrow keys to move the selection up or down. Use Find… from the Action menu (Cmd+F) to se
lect a Sound or file by name. The Action and Info menus refer to the selection. Use Cmd+Space or the 
transport controls to audition the selection. Click and drag the selection into a time line, Sound editor, 
or Sound file window to use the selection in your work.

Information on the selected Sound, file or folder.
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—  SPECTRUM  EDITOR  —
The spectrum editor displays the amplitude and frequency envelopes of sine 
wave components to be used during additive resynthesis. Each horizontal 
track represents a single sine wave. Color indicates the amplitude of the sine 
wave, vertical position indicates the frequency of the sine wave, and horizon-
tal position indicates time. The spectrum editor uses the Capybara for real 
time auditioning of the resynthesis while editing.

The yellow scrub bar can be moved with the mouse, with MIDI pitch bend, or 
left or right arrow keys. While the scrub bar is moving, the resynthesis will play.

Markers indicate labeled time points and time segments for cutting or audi-
tioning. The white marker is selected and its time position and label are dis-
played at the top of the editor.

Click a marker to select it; the scrub bar moves to the marker time. Press 
Enter to rename the selected marker; use the Delete key or Cut from the 
Edit menu to remove the selected marker.

These buttons do the following: creates a marker at the scrub bar time; pla-
ces the start marker at the scrub bar; places the end marker at the scrub 
bar; and sets pre- and post-roll play times.

These buttons do the following: play the entire spectrum; play the selection; 
play the selection between start and end markers; and play the selection out-
side of start and end markers.

Information on the track under the cross hair cursor is displayed here.

Zero the amplitude of the selected tracks by choosing Clear from Edit menu. 
Grayed tracks have zeroed (cleared) amplitudes.

These buttons do the following: modify the selection in various ways; cut the 
time between the start and end markers; and switch in and out of drawing mode.

These buttons do the following: zoom the display all the way out; switch be-
tween time-frequency and time-amplitude display modes; switch between iso-
lated-dot and connected-dot between spectral frames; select tracks and 
frames based on various criteria.

Selected tracks are brighter. Select by clicking on an individual track, or by 
drawing a box around a region to select. Hold the Shift key while selecting to 
add to or remove from the current selection. Select a track between 1 and 10 
by pressing a number key (1-9, 0). Up and down arrow keys select next higher 
or lower track.

Create a Sound to play the selected part of the spectrum by choosing Copy 
from Edit menu, then Paste into a time line, Sound editor, or Sound file window.

Hold down the Control or Command key while drawing a box to zoom in on a 
specific region.
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